CSC Phone System Outage

Incident Report for M/D Totco

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 11:00 CDT

Identified

The Customer Support Center phone system is currently experiencing an outage. We will update the status here as soon as the service is restored.
Posted Oct 20, 2025 - 07:04 CDT
This incident affected: Support Center (Outgoing Calls, Incoming Calls).