Performance Degradation – WellData.ca

Incident Report for M/D Totco

Resolved

The issue causing performance degradation for some users has been resolved, and service has been restored. We have taken steps to protect service stability and will continue to monitor the environment. Thank you for your patience while we worked to resolve this issue.
Posted Aug 28, 2026 - 18:49 CDT

Monitoring

Canadian services are coming back online now but performance may be impacted as we continue to investigate and work toward a resolution. We will post additional updates as the situation changes.
Posted Aug 28, 2026 - 16:38 CDT

Identified

We are currently investigating an issue affecting WellData.ca that may result in degraded performance or limited functionality for some users. Our team is actively working to identify the root cause and restore full service as quickly as possible.

We will provide an update once the issue has been resolved or as more information becomes available.

For the latest system status, please visit: https://status.mdtotco.com
Posted Aug 28, 2026 - 16:05 CDT
This incident affected: WellData.ca (Canada) (Website - www.welldata.ca, WellData RealTime, Max Drilling mobile app, WITSML).