Performance Degradation – WellData.net

Incident Report for M/D Totco

Resolved

This incident has been resolved.
Posted Mar 01, 2026 - 23:15 CST

Monitoring

We have resolved the issue and services have been restored to normal operation. We will continue actively monitoring the system to ensure stability.

For the latest system status, please visit: https://status.mdtotco.com
Posted Feb 24, 2026 - 11:48 CST

Identified

We have identified the root cause of the issue affecting WellData.net that resulted in degraded performance for some users. Our team is working to restore full service as soon as possible. We will provide additional updates as progress continues.

For the latest system status, please visit: https://status.mdtotco.com
Posted Feb 24, 2026 - 11:16 CST

Investigating

We are currently investigating an issue affecting WellData.net that may result in degraded performance or limited functionality for some users.

Our team is actively working to identify the root cause and restore full service as quickly as possible.

We will provide an update once the issue has been resolved or as more information becomes available.

For the latest system status, please visit: https://status.mdtotco.com
Posted Feb 24, 2026 - 08:58 CST
This incident affected: WellData - US (Website, www.welldata.net, WellData RT, Max Drilling Mobile, WITSML) and Max Drilling – WellData 4.0, WellData REST API.